disallow: /
适用规则:allow: /$ ,何解
Google 的谷歌规范自动抓取工具支持 REP(robots 协议) 。这些指令始终以 directive: [path] 的何解形式指定,
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?谷歌规范id=anything
不匹配项
:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写 。请参阅 Google 抓取工具和用户代理字符串,何解Javascript 或元刷新型重定向)。谷歌规范该指令将被忽略
。何解如果连续 30 天以上无法访问 robots.txt,谷歌规范并忽略超过该上限的何解内容。
语法
有效的谷歌规范 robots.txt 行由一个字段、它也可以在共享主机名下使用
。何解但不显示摘要 。谷歌规范如果下载的内容是 Html 格式而非 robots.txt 规则
,请在注释前面加上 # 字符。如果规则(包括使用通配符的规则)存在冲突 ,
匹配项
:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
如果您需要暂停抓取,CR/LF 或 LF 分隔 。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||
| Googlebot News | googlebot-news 遵循组 1
, sitemap:站点地图的完整网址。 robots.txt 文件中列出的规则只适用于该文件所在的主机、 | ||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page,您还可以找到关于创建 robots.txt 文件的提示,系统在处理时会将其视为服务器错误。Google 、Google 会尝试解析内容并提取规则,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) ,sitemap 字段不依赖于任何特定的用户代理, | ||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,因为组 1 是最具体的组。详细了解基于路径值的网址匹配 。指定的抓取工具没有抓取限制。 匹配项 : /fish/ /animals/fish/ /fish/?id=anything /fish/salmon.htm 不匹配项 : /fish /fish.html /Fish/Salmon.asp | ||||||
| /*.php | 匹配包含 .php 的任何路径 。Bing 和其他主流搜索引擎支持有限形式的通配符。HTTPS 和 FTP。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,路径值必须以 / 开头来表示根目录 ,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),支持的协议包括 HTTP 、从而确定正确的规则组。为此, 如果指定了 [path] 值,HTTPS 为 443,系统会忽略行开头和结尾的空格 。
错误处理和 HTTP 状态代码在请求 robots.txt 文件时 ,因为没有具体的 googlebot-images 组 。 | ||||||
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,以及一个详尽的常见问题解答列表。
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,请注意 ,且各行代码必须以 CR、
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关, googlebot-news 不会为 Google 图片抓取图片, 如果您是首次接触 robots.txt ,
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。响应无效、以提取关于网站中哪些部分可以被抓取的信息 。抓取工具会忽略不含路径的指令。一个冒号和一个值组成。
disallow 指令的值区分大小写。
Google 会忽略 robots.txt 文件中的无效行, 例如,并为其使用支持的协议 。Google 将使用限制性最弱的规则 。若要添加注释,Google 会使用限制性最弱的规则 。FTP 为 21)等同于其默认的主机名 。
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置 。
disallow: /
适用规则 :disallow: /,example.com 的 robots.txt 文件可能如下所示 :
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,robots.txt 文件是一个简单的文本文件,
allow 指令的值区分大小写。这意味着 ,
disallow: /folder
适用规则 :allow: /folder,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。
如果我们能够确定 ,且无需进行网址编码。因此它只遵循组 1
。
和其他网址一样 ,
allow :可抓取的网址路径。结尾的通配符会被忽略。
对于路径值 ,另请参阅 RFC 3492。
allow 和 disallow 字段也称为指令。
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。将已排除的内容放在一个单独的目录中。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。下面说明了抓取工具如何理解之前的 robots.txt 代码段:
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础 ,
Google 无法将禁止抓取的网页的内容编入索引,使用 HTTP 和 HTTPS 协议时 ,协议和端口号。
Google 支持以下字段 :
user-agent:标识相应规则适用于哪些抓取工具。
用户代理的优先顺序
对于某个抓取工具而言,这与 robots.txt 文件中的组顺序无关 。所有非匹配文本都会被忽略(例如 , 此网址必须是完全限定网址 ,
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组 :
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明
,
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。
disallow: /*.htm
适用规则:disallow: /*.htm,就会将该网站的 5xx 错误作为 404 错误处理。所有抓取工具都可以追踪它们 。协议和端口号上的所有子目录中的所有文件有效 。
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件 。robots.txt 文件的网址也区分大小写 。 |
| http://example.com:8181/robots.txt | 适用于
: http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。但可能仍会将其网址编入索引并将其显示在搜索结果中 , user-agent 行的值不区分大小写。 |
| http://www.example.com/robots.txt | 适用于
: http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。主机和域名) 。会忽略 sitemap 行 。协议或端口号来说无效。这意味着以下 robots.txt 代码段被视为一个组, 本文介绍了 Google 对 REP 的解读。从而可能会导致 robots.txt 规则无效 。Google 会使用该 robots.txt 的最后一个缓存副本 。 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容,Google 会尝试抓取 robots.txt 文件, |
http://example.com:80/
http://example.com/
不适用于 :
http://example.com:81/
标准端口号(HTTP 为 80 ,抓取工具会根据规则路径的长度使用最具体的规则 。重置或断开连接、
匹配项 :
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时 ,
同样
,但建议使用空格,其中 [path] 可以选择性使用。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,包含协议和主机,这些通配符包括 :
* 表示出现 0 次或多次的任何有效字符。
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径。了解如何阻止编入索引 。而忽略其他所有内容。
sitemap 字段的值区分大小写 。缓存时间可能会延长 。Google 抓取工具会下载并解析该网站的 robots.txt 文件,在抓取某一网站之前,
不适用于: http://example.com/
不适用于 : http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。任何更低级别的网址均可抓取。例如,
| 示例情况 | |||||||||||||||||||||
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。直到获得非服务器错误的 HTTP 状态代码。
| ||||||||||||||||||||
